
Ritchey-Common Testing of Large Flats Using a 
Commercial Interferometer

Introduction
Ritchey-Common testing is an accurate method
for characterizing the surface shape of large
optical flats. With newly available analysis
software, this procedure can now be
implemented using a commercial Wyko® laser
interferometer, to accurately isolate the shape 
of a test flat or mirror.

Ritchey-Common Procedure
Because of its speed and accuracy, interferometry is commonly
employed to measure large optics. The largest commercial phase
shifting interferometer, the Wyko RTI 24100, is capable of
measuring optics up to 24 inches (610mm) in diameter.

Astronomical projects, however, often require optics on the order
of 1m or more in diameter. Designing a custom interferometer with
an aperture of this size could prove to be prohibitively expensive.

In the Ritchey-Common method, the test beam is directed through
a transmission sphere, such that its diameter increases with
distance. The test flat is inserted into the optical path at an angle,
typically 45 degrees. A return sphere slightly larger than the test
flat folds the beam back through the optics to the interferometer.
(Figure 1). This method enables the use of a, readily-available,
smaller-aperture interferometer.

Because the flat is placed at an angle in the optical path, the
resulting dataset becomes elliptical. Power, a common error for
large flats, appears as both power and astigmatism in the test
wavefront. Other aberrations are naturally skewed in the
wavefront data as well. To solve for these additional variables,
multiple measurements are taken at various degrees of rotation.
Measurements at 30, 60 or 90 degree intervals will serve,
though accuracy improves as the size of the increment decreases.

The Ritchey-Common procedure consists of 4 sections:

1. Measure the optical distortion of the system

2. Determine the actual incidence angle of the test flat

3. Measure the empty cavity as a reference

4. In software, determine the test flat’s shape.

Each section will be described below. For a complete
mathematical description please refer to Sen Han’s paper,
"Application of Ritchey-Common Test in Large Flat Measurements."1

Equipment List
Interferometer  For this procedure we recommend a Wyko RTI
Series Laser Interferometer for its accuracy and ease of use. 

Return Sphere  A return sphere slightly larger than the test flat is
required. Since its shape will be subtracted from the measurement,
it can be of lower quality (λ/5 or better). Reflectivity on the order
of 4% is sufficient if the test surface has 90% or higher reflectivity.
If the test surface is of low reflectivity, the return sphere should have
90-95% reflectivity. A radius of curvature (ROC) of 4 * Diameter is
most common. 

If the incidence angle of the test piece is 45°, the F/# should be 4
or slightly larger. The F/# should be larger if the incidence angle is
larger. As an example, for a 1m diameter test sample, the diameter
of the return sphere should be approx. 1.1m, and the ROC should
be greater than 4.4m. The F/# should be 4.

Transmission Sphere  The diameter of the transmission sphere
should match the aperture of the interferometer. Its F/# should be
close to that of the return sphere. Since RTI Series interferometers
include a 7X zoom, the F/# can be approximate, allowing use of
an off-the-shelf sphere. If the test sample is of low reflectivity, the
transmission sphere should have a 0.16-0.25% coating.

Mounts  5-axis mounts, with at least 5mm X and Y translation, 
are required for the test flat and return sphere. The test sample
mount must also have 180 degrees of rotation (± 0.1º accuracy).
The optics should sit against hard stops in the mounts, such that 
if the optics are removed they can be replaced with only 
minor refocusing. 
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Figure 1. Caption for Intrferometer goes here. 



Note: X is measured from the cat’s eye position, not from the
transmission sphere or interferometer.

11. Position the test flat as closely to 45 degrees as possible (we will
determine the actual angle later).

12. Adjust the tip, tilt and position of the return sphere until the beam
passes back through the pinhole.

13. Remove the pinhole flag.

14. Adjust tip and tilt on the return sphere to obtain good fringes
across the test surface (Figure 3).

15. Verify that the test beam is roughly centered on the return sphere.
Watching the intensity screen, move a card or piece of paper in
front of the return sphere, to the right and left, and above and
below. The shadow of the card should block roughly the same
amount of space all the way around. If it does not, adjust the
return sphere in X and Y, null the fringes, and check again.

16. Mark the position of the corners of both mounts on the isolation
table, such that you can reposition the mounts later in the test.

Measuring Overall System Error

You will now perform a series of measurements at multiple rotational
angles. Wyko® Vision32 software, included with RTI Series
interferometers, will use this data to solve for the test surface shape.

Vision32 also includes an on-screen guide to walk you through the test
procedure. In this example we will make the individual measurements,
then we’ll use the guide to load the files into Vision32.

17. In Vision, Under Measurement Options>PSI Options, set the
Wedge factor to 0.25.

18. Click the New Measurement button. 

19. Save this file as "0 Degrees.opd."

Figure 2. Align the flat so that it remains perpendicular throughout
rotation

The return sphere mount will be relocated during the test, so
provisions must be included for easy movement.

Other Requirements
The procedure also requires:

• a vibration isolation system large enough to support the 
entire apparatus

• a laser for alignment (a 633 HeNe is sufficient)

• a transmission flat (the diameter should match the 
interferometer aperture)

• a pinhole flag to aid in alignment

• an erasable marker to note positions on the isolation table

• fine, stranded wire for use as crosshairs.

Measurement Procedure
Though this procedure is designed for measuring large optics, the
following example uses a small, 3-inch flat for clarity. We employ a
digital radius slide for ease of positioning, but it is not required. 

Aligning and Focusing the System

1. Set up the interferometer on an isolation system, in a room with
minimal vibration and air movement.

2. Load the transmission flat into the interferometer.

3. Align the flat using Alignment Mode.

4. Load the test flat into its mount and position it exactly
perpendicular to, and less than one foot away from, 
the aperture. 

TIP: If you are using a chuck-type mount, be sure to position the
flat toward the tips of the chuck. Otherwise, at a 45 degree
angle the chuck tips may obscure part of the measurement area.

5. During the procedure, you will rotate the flat to make multiple
measurements. To ensure that it will remain perpendicular to the
optical path as it rotates, use Alignment Mode to adjust the tip
and tilt of the flat and rotation adapter (Figure 2). Rotate the flat,
adjusting the tip/tilt controls and verify that it remains aligned
throughout rotation.

6. As a final check, return to Measurement Mode. Verify that 
you can retain fringes as you rotate the test flat. If not, repeat
Step 5.

7. Adjust the intensity to just below saturation.

8. Replace the transmission flat with the transmission sphere.

Next you will ???? to position the test flat and return sphere. 

9. Place the pinhole flat at the "cat’s eye" position.

10. Referring to Figure 1, position the two mounts. The distant 
X +Y must equal the return sphere’s radius of curvature. 
X should be maximized and Y minimized, to the largest practical
extent, to ensure that the entire test flat falls within the expanding
test beam. The positions should be accurate 
to within approximately 1mm.



20. Rotate the test flat to the next position. You can choose to
measure every 30, 60 or 90 degrees.  

TIP: We recommend measuring every 30 degrees for the
highest accuracy.

21. Adjust the test flat’s tip and tilt to null the fringes.

22. Take a measurement and save the file as "30 Degrees.opd".

23. Repeat Steps 20-22 for each measurement up to and
including 180 degrees.

Measure the Ritchey-Common Angle

For highest accuracy we need to precisely measure the incidence
angle of the test flat (the Ritchey-Common Angle).

24. Place the pinhole flag at the cat’s eye position.

25. Insert a laser between the transmission sphere and the
pinhole flag. 

26. Align the laser such that its beam passes through the pinhole,
through the optical system, then back through the pinhole
(Figure 4).

27. Mark the table at the spots where the beam passes through
the pinhole and contacts the test flat and return sphere.

28. Measure the distances a, b and c.

29. Compute the Ritchey-Common Angle by: 

where s= _ (a+b+d).

Measuring the Empty Cavity

One more "reference measurement" will isolate the shape of the
return and transmission spheres. For this measurement you will
remove the test flat from the optical path, then relocate the return
sphere in front of the interferometer. To accurately subtract the shape
of the return sphere, it must maintain the same distance from the
transmission sphere as during the rest of the procedure. The test
beam must reflect from the same area of the sphere as well.

30. Tape three wires to the return sphere to form a triangle 
(Figure 5). These crosshairs will aid in alignment when you
move the return sphere.

31. Adjust focus and tip/tilt to null the fringes.

32. Take a measurement and save this file as "Fiducial.opd."

33. Move the test flat and its mount out of the optical path.

34. Reposition the return sphere in front of the interferometer at a
distance exactly equal to X+Y from Figure 1. 

35. Adjust tip and tilt to null the fringes.

36. Take a measurement.

37. This data is the mirror image of data from the original
measurement setup. Flip the image by choosing Edit>Modify
Data>Flip in Y.

38. Save the dataset as "Fiducial2.opd."

Figure 3. Fringes on test surface
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Figure 3. Use a laser to determine the Ritchey-Common Angle

Figure 5. Attach three crosshairs to the return sphere.
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Conclusion
The Ritchey-Common methods provides a highly accurate
measurement of a large optic’s surface shape. The ability to make
this measurement using a commercially-available interferometer and
analysis software will greatly aid in the efficient, cost-effective
manufacture of new optics..
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Practical Considerations
Eliminate environmental effects. Reducing vibration, air turbulence,
and temperature variability are well known techniques for improving
test results. All flats should be kept at room temperature to avoid
thermal drift. 

Your isolation system for this test must be large enough to
accommodate all of the test apparatus. An air table may not be
large enough; an isolation system mounted in a sub-floor may be
more appropriate.

.

39. In Vision32 choose File>Subtract/Add Files. Select
"Fiducial.opd" and "Fiducial2.opd" and select the
"Subtract" option. The result should show two sets of
crosshair wires, one from the each measurement. 

40. Adjust the position of the return sphere, then repeat Steps 35-
38 until the crosshairs perfectly align (i.e., only one set
appears in the subtracted data). 

TIP: Some diffraction will occur around the wires, but you can
typically align the crosshairs to within 3 pixels. 

41. When you are satisfied with the alignment, remove the
crosshairs from the return sphere.

42. Null the fringes and take the reference measurement. 

43. Choose Edit>Modify Data>Flip in Y, then save the data as
"Cavity.opd."

Analyzing the Data

44. Choose File>Special Measurement>Ritchey-Common
Measurement. The online guide dialog box will open.

45. Check the "Read Files" box to load data from the existing
measurement files.

46. Enter the test flat’s radius and the distance X (from the cat’s eye
to the sample).

47. Choose "Positive" if the sample flat angles to the left, as in
Figure 1, or "Negative" if it angles to the right.

48. Enter the measured Ritchey-Common Angle.

49. Under "Rotations" choose the number of measurements that
you generated during the test.

50. Click "Measurement Reference" and select the
"Cavity.opd" dataset.

51. Click "Measure Step 1" and select the "0 Degrees.opd"
dataset.

52. Continue through each measurement step, selecting each
dataset in order.

53. Click "Done". Vision32 will display the surface shape of the
test flat as well as parameters describing the shape.


